Ram Heavy Duty Forum

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Uconnect 5 nav issue

Myfast70

Well-Known Member
Joined
May 27, 2021
Messages
479
Reaction score
605
First off the TomTom nav sucks! It cannot find a couple addresses that have existed for several years now and is nowhere near as good as the maps that is built in my Galaxy or even an iPhone.

Next, how do I get it to read in the imperial system vs metric system? It has the distances to turns, exits, speed limit (km/h) and such in meters & km which is pretty annoying. I've gone thru most every setting that I can find and whatever options I found are already set to mph (still reads I'm km/h) but I couldn't find one for the distance to exit. I've already got an open case with Uconnect for totally buggy issues with the app controlling the remote features of the truck.

Any real help would be greatly appreciated!
 

Snaps3500

Member
Joined
Dec 28, 2020
Messages
39
Reaction score
55
Good day,
I would enter the drivers cluster menu where the digital speedometer is shown and if you look below that slows reading you will see instructions on how the change from imperial to metric, I adjust
Mine with the menu arrows on the steering wheel on the left side. Hope this helps.


Sent from my iPhone using Tapatalk
 

Myfast70

Well-Known Member
Joined
May 27, 2021
Messages
479
Reaction score
605
Good day,
I would enter the drivers cluster menu where the digital speedometer is shown and if you look below that slows reading you will see instructions on how the change from imperial to metric, I adjust
Mine with the menu arrows on the steering wheel on the left side. Hope this helps.


Sent from my iPhone using Tapatalk

Thank you for the reply! I was trying to change it on the maps but it has since switched to imperial and has stayed that way. Still a few other small bugs & glitches but the latest OTA update has made an improvement in functionality
 

Users who are viewing this thread

Top