Ram Heavy Duty Forum

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Phone calling itself on my Uconnect system

RamGuy84

Active Member
Joined
May 17, 2019
Messages
366
Reaction score
159
Has anyone else experienced this? If Bluetooth is connected and I’m on my phone, usually certain apps and websites will cause my phone to call itself. When I had my Ford with Sync 3 that never happened. Maybe it’s normal, idk.
 

@JC

Well-Known Member
Joined
Jan 22, 2020
Messages
306
Reaction score
278
Never had that happen on any of my Uconnect enabled vehicles.
 

MSundet

Active Member
Joined
Mar 14, 2020
Messages
195
Reaction score
161
I had that today and yesterday


Sent from my iPhone using Tapatalk
 

MSundet

Active Member
Joined
Mar 14, 2020
Messages
195
Reaction score
161
It’s very annoying

I don’t know if it was a malfunction of the phone or the truck, sometimes I believe it’s the malfunction of my phone not being able to connect properly I don’t know
 

RamGuy84

Active Member
Joined
May 17, 2019
Messages
366
Reaction score
159
If I access apps like Snapchat, or certain websites, it starts calling itself.
 

1FastHemi

Well-Known Member
Joined
Jan 4, 2020
Messages
407
Reaction score
316
Have you tried the following?

Un-pairing your phone from the vehicle,
Turn your phone off for a several minutes,
Turn switch off to vehicle and leave the vehicle for a few minutes,
Then turn your phone back on,
Then return to the vehicle and pair your phone back up again.

P.S Make sure your leave several minutes between each step mentioned above.

Sometimes that will fix some things I have found out unless it is another issue.
 
Last edited:

RamGuy84

Active Member
Joined
May 17, 2019
Messages
366
Reaction score
159
Yes. This has been an ongoing issue since I got it in August, among the other many issues I’ve had.
 

MikeXM

Well-Known Member
Joined
Nov 30, 2019
Messages
750
Reaction score
675
If you guys search this on Google you will see that it is not an isolated issue. Both Android and iPhones. Ford, BMW, Tesla, etc.

So it is not related to uConnect only. And not just one brand of phone.

There's seems to be many solutions too. So you should try to find one that works for you using Google.
 

MSundet

Active Member
Joined
Mar 14, 2020
Messages
195
Reaction score
161
Have you tried the following?

Un-pairing your phone from the vehicle,
Turn your phone off for a several minutes,
Turn switch off to vehicle and leave the vehicle for a few minutes,
Then turn your phone back on,
Then return to the vehicle and pair your phone back up again.

P.S Make sure your leave several minutes between each step mentioned above.

Sometimes that will fix some things I have found out unless it is another issue.

Of course this has been an ongoing issue with many manufacturers but just more annoying when the old U connect never seemed to have issues...
 

RamGuy84

Active Member
Joined
May 17, 2019
Messages
366
Reaction score
159
When I first got the truck I would be having a conversation via Bluetooth and after 10+ minutes, the person I was talking to could no longer hear me, though the connection was still there. I took it in with my wobbly hood and “couldn’t be replicated” of course.
 

GLB1950

Active Member
Joined
Aug 27, 2019
Messages
76
Reaction score
151
Location
PNW
While in my wife's Murano, on several occasions, I've received calls from my Dr and my cousin (special ring tones). never anybody there. Ghost rings.
 

Burn'n Oil

It's a metaphor!
Joined
Oct 3, 2019
Messages
841
Reaction score
541
Location
Great White North
Had an old Sammy S4 plugged into the system initially and now a S10 - no issues. However, the boss was getting PO'd last summer when we was on the the road with the roll'n dog house. Every time she was doing the text thing, Uconmect would try to pair with her phone. Finally convinced her just to do it.
 

2014 Red Laramie

New Member
Joined
Nov 2, 2021
Messages
1
Reaction score
0
Has anyone else experienced this? If Bluetooth is connected and I’m on my phone, usually certain apps and websites will cause my phone to call itself. When I had my Ford with Sync 3 that never happened. Maybe it’s normal, idk.
Mine started doing that yesterday. Says “My Phone” and the call blocks the radio from playing, obviously. I had to delete my phone to get it to stop.
 

Users who are viewing this thread

Top