Ram Heavy Duty Forum

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Dealership caught unhooking dash cam, ridiculing owner, admitting there is a problem, but lying on paperwork, and possibly illegally changing miles

Possum

Member
Joined
Dec 2, 2019
Messages
74
Reaction score
54
@RamCares

I have a situation and existing case # but I want to discuss these issues here.

My dash is busted and pieces are falling out, screws missing.

I have reason to believe they illegally modified my mileage before getting the truck back.

I have audio of them admitting the truck will not start properly but on the paperwork saying they couldn't duplicate.

I have audio of them disparaging me, the owner, calling me a "****ing retard" because I didn't want them to take my truck through some serious off-road articulation to replicate the body mount noise after driving with them 3 times in the past and fully diagnosing it. After doing all the rides and diagnosis they asked for, they said they needed to drive just like I did but with out me. It seemed like a waste of time. I clearly had reason to be suspicious as they unhooked my dash cam for much of the stay at the visit.

Dash cam was disconnected or files deleted after a few days at the dealer, and turned back on a day before picking it up.

In the first video after they reconnected it, there is audio of the tech reading off mileage and appears to be typing it into something, and then reading it off to confirm the mileage is correct before turning the truck back off. I have suspicion that they were illegally modifying the mileage. Is there any way to see if the mileage has ever been changed?

The AC still isn't fixed like they said it was.

There is a huge scratch on my grill that wasn't there before. Looks like a belt buckle caught it.

Many factory upgrades (like LED headlights, fog lights, etc) would not work because they disabled those features while they had my truck. I couldn't drive my truck the next night because the lights would not come on.

I have been to this dealership at least 5 times and it has been nothing has been fixed, only more damage has taken place.

I called corporate before reviewing the footage and they said I had to keep taking it back there. I will not take my truck back to this dealership.

This needs to be addressed very soon, or I will be taking the audio to a local reporter that has expressed interest in it.
 

Possum

Member
Joined
Dec 2, 2019
Messages
74
Reaction score
54
Also, the TSB (23-047-18) for the body mounts clearly says to replace all 8 body mounts, but they only replaced the 3 that are furthest from the point where the noise was coming from. I also have audio of the tech saying those 3 were trashed and the other 5 need to be replaced, but they didn't replace them and sent the truck back out with body mounts they know needed to be replaced.

So this is also a safety issue they are not taking seriously.
 

CFE

Active Member
Joined
Jan 3, 2022
Messages
195
Reaction score
136
@RamCares

This needs to be addressed very soon, or I will be taking the audio to a local reporter that has expressed interest in it.

Hope you find a dealer that can assist you without the hassle - but I personally would let the local reporter run with the audio if that dealership has a history of bad reviews/customer service.
 

Crusty old shellback

Well-Known Member
Joined
Apr 10, 2021
Messages
2,354
Reaction score
3,393
I definatly would not be taking my truck back to that dealer. I'd be finding another one.
And I would be reporting the incidents up the RAM chain till I got some real answers other than go back to the screwed up dealer.
 

Possum

Member
Joined
Dec 2, 2019
Messages
74
Reaction score
54
Also, my truck failed to start over the weekend. Just kept cranking for a long time and died right as it was about to turn over. It started the 2nd try. I have video to confirm it.
 

Darmichar

Active Member
Joined
Jan 26, 2022
Messages
212
Reaction score
169
Hope you find a dealer that can assist you without the hassle - but I personally would let the local reporter run with the audio if that dealership has a history of bad reviews/customer service.
Agreed. Ram or not, if a dealership is that shady people need to know.
 

RamCares

RamCares Team
Joined
Mar 25, 2019
Messages
867
Reaction score
544
@RamCares

I have a situation and existing case # but I want to discuss these issues here.

My dash is busted and pieces are falling out, screws missing.

I have reason to believe they illegally modified my mileage before getting the truck back.

I have audio of them admitting the truck will not start properly but on the paperwork saying they couldn't duplicate.

I have audio of them disparaging me, the owner, calling me a "****ing retard" because I didn't want them to take my truck through some serious off-road articulation to replicate the body mount noise after driving with them 3 times in the past and fully diagnosing it. After doing all the rides and diagnosis they asked for, they said they needed to drive just like I did but with out me. It seemed like a waste of time. I clearly had reason to be suspicious as they unhooked my dash cam for much of the stay at the visit.

Dash cam was disconnected or files deleted after a few days at the dealer, and turned back on a day before picking it up.

In the first video after they reconnected it, there is audio of the tech reading off mileage and appears to be typing it into something, and then reading it off to confirm the mileage is correct before turning the truck back off. I have suspicion that they were illegally modifying the mileage. Is there any way to see if the mileage has ever been changed?

The AC still isn't fixed like they said it was.

There is a huge scratch on my grill that wasn't there before. Looks like a belt buckle caught it.

Many factory upgrades (like LED headlights, fog lights, etc) would not work because they disabled those features while they had my truck. I couldn't drive my truck the next night because the lights would not come on.

I have been to this dealership at least 5 times and it has been nothing has been fixed, only more damage has taken place.

I called corporate before reviewing the footage and they said I had to keep taking it back there. I will not take my truck back to this dealership.

This needs to be addressed very soon, or I will be taking the audio to a local reporter that has expressed interest in it.
Hi Possum,

We appreciate you bringing this to our attention, as we can understand the severity of this. We'd really like to be able to assist with this. Can you please send us your case number via private messaging?

Callie
Ram Cares
 

arx237

Well-Known Member
Joined
Oct 15, 2021
Messages
348
Reaction score
464
Hope you find a dealer that can assist you without the hassle - but I personally would let the local reporter run with the audio if that dealership has a history of bad reviews/customer service.
Id check with legal counsel first. Depending on the state this may be inviting a whole new set of problems.
 

Possum

Member
Joined
Dec 2, 2019
Messages
74
Reaction score
54
Id check with legal counsel first. Depending on the state this may be inviting a whole new set of problems.

I informed them of the dash cam and that it records when I dropped it off, but most of the recordings I have are from conversations I was a part of. Completely legal in my state.

I didn't have the dash cam in there to spy on anyone, it's hardwired into the truck and always on when the truck is on. But I did let the guy know about it when I was giving them my keys.

ETA 2: It also has a startup noise to let you know it's on and a bright light showing it's recording and another light showing the mic is enabled.
 

Possum

Member
Joined
Dec 2, 2019
Messages
74
Reaction score
54
@RamCares

Just recovered some video from the dash cam of the service advisor hot rodding my truck, driving it 91+ mph. Zero reason to drive this fast for any issue I brought it in. This is a large and heavy 2500 Tradesman work truck. I brought it in for the AC, hard start, and body mount issue (that only happened during slow articulation).


91 mph.png
 

Arth

Member
Joined
Jul 15, 2021
Messages
59
Reaction score
64
@RamCares

Just recovered some video from the dash cam of the service advisor hot rodding my truck, driving it 91+ mph. Zero reason to drive this fast for any issue I brought it in. This is a large and heavy 2500 Tradesman work truck. I brought it in for the AC, hard start, and body mount issue (that only happened during slow articulation).


View attachment 41707

Ahh yes. Reasons why I also run a dash camera. Interested to hear an explanation for this one.
 

Possum

Member
Joined
Dec 2, 2019
Messages
74
Reaction score
54
Ahh yes. Reasons why I also run a dash camera. Interested to hear an explanation for this one.
In the 2-3 years I've had this dash cam, not once have I had a corrupted video. There are two corrupted videos that show up in windows explorer and I ccouldn't recover those. About a week of footage is missing. I was able to retrieve this one though. I'm going to try to fix the corrupted videos.
 

jadmt

Well-Known Member
Joined
Aug 29, 2020
Messages
2,166
Reaction score
2,777
Age
64
Location
Missoula
@RamCares

Just recovered some video from the dash cam of the service advisor hot rodding my truck, driving it 91+ mph. Zero reason to drive this fast for any issue I brought it in. This is a large and heavy 2500 Tradesman work truck. I brought it in for the AC, hard start, and body mount issue (that only happened during slow articulation).


View attachment 41707
Wow hope heads roll.
 

g00fy

Well-Known Member
Joined
Mar 3, 2020
Messages
526
Reaction score
569
Many factory upgrades (like LED headlights, fog lights, etc) would not work because they disabled those features while they had my truck. I couldn't drive my truck the next night because the lights would not come on.

Sounds like you've got a really bad service dept. working on your truck and Stellantis needs to step in and make this right.

I will say though, you can't fault them for your post production upgrades not working. Whenever they have to do a software update or anything, the truck gets reset back to factory defaults. Happened to my truck many times after service visits, I just keep an AlfaOBD back up handy and reupload it when I get the truck back.
 

Possum

Member
Joined
Dec 2, 2019
Messages
74
Reaction score
54
the picture looks like he is on the highway getting ready to exit?

Yeah it's at the end of a bypass where it splits to go north or south onto a 4 lane road running north and south. It's 60 mph coming into this area and changes to 40 right before it splits. So he was doing 50 over the speed limit.
 

Users who are viewing this thread

Top