Ram Heavy Duty Forum

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

2022 Uconnect 5 12.0 Glitches

Blythkd1

Well-Known Member
Joined
Feb 8, 2022
Messages
336
Reaction score
416
I'm beginning to develop the firm opinion that the majority of my 12.0 screen glitches are happening when my phone is plugged in to charge. I noticed a few days ago that an update is ready to load. Does anyone know anything about the update and what it might fix?
 

Gkockrow

Member
Joined
Aug 24, 2021
Messages
68
Reaction score
17
Anyone else on here have their 22 2500 with the 12" display in yet? My radio and apple carplay is super glitchy...

[MOD: Update file posted here: https://hdrams.com/forum/index.php?threads/2022-uconnect-5-12-0-glitches.7144/page-12#post-172414 ]
Mine is also. Can’t pair phones , can’t get rid of sales pitch for u connect at startup, navigation not as accurate as my 2017. Was told to do hard reset but just wiped out all settings. Very disappointed. 1900.00 for 12 inch screen. Taking to dealership but I have my doubts after what I read.
 

Darmichar

Active Member
Joined
Jan 26, 2022
Messages
212
Reaction score
169
I'm beginning to develop the firm opinion that the majority of my 12.0 screen glitches are happening when my phone is plugged in to charge. I noticed a few days ago that an update is ready to load. Does anyone know anything about the update and what it might fix?
Mine is the exact opposite, I get more issues when I use wireless CarPlay. Based on what I've been able to gather, it seems like the processor they used for the infotainment is woefully underpowered and can't handle what's being thrown at it.
Found a new issue driving the other day driving in spotty rain. The auto-headlights would come on with the wipers, the screen would change from light to dark and crash the system. Good times.
 

Blythkd1

Well-Known Member
Joined
Feb 8, 2022
Messages
336
Reaction score
416
Mine is the exact opposite, I get more issues when I use wireless CarPlay. Based on what I've been able to gather, it seems like the processor they used for the infotainment is woefully underpowered and can't handle what's being thrown at it.
Found a new issue driving the other day driving in spotty rain. The auto-headlights would come on with the wipers, the screen would change from light to dark and crash the system. Good times.
I may have a wireless issue as well, not quite sure yet. I'll keep an eye on it now but I'm wondering if my bluetooth being on at times plus being plugged in may be causing problems as well. I typically don't have my bluetooth on but may be on from time to time. I'll watch for it.
 

MikeXM

Well-Known Member
Joined
Nov 30, 2019
Messages
816
Reaction score
743
My comment isn't going to help anyone, but holy cow uconnect 5 is such a mess. It was supposed to be based on a faster processor. It's actually not as responsive as previous gen. Every single time I used one there was something that went bad. From huge lags to bugs, etc. Like yesterday, in a Grand Wagoneer, Car Play completely disappeared after working for a few minutes. Impossible to get it back to work again. Like it crashed and would not start again. Even after turning off the GW. Phone was paired and Carplay enabled. But nowhere to be found.

I'm very happy with my previous gen uconnect. Sorry for you guys.
 
Last edited:

jebruns

Active Member
Joined
Feb 28, 2022
Messages
333
Reaction score
207
I had the 8.4" uConnect 4 in the 18 Ram 2500 I traded on my 22 2500, which has the 12" uConnect 5. I experience no lag whatsoever on 5, and it is certainly not slower than 4 in any way. Both are very snappy, in my experience.

Now, the wife has a 21 Pacifica with the premium system and uConnect 5. That this is slow, at least on initial startup. Takes a while for the home screen to come up. I find it frustrating since I drive it so infrequently, but the wife doesn't complain.

uConnect 5 is certainly glitchy though. We've had USB drive issues with both, and I never know what home screen is going to come up in the Ram at startup. But overall, I really like it and is stable beyond that (knock on wood!).
 

Blythkd1

Well-Known Member
Joined
Feb 8, 2022
Messages
336
Reaction score
416
It gets pretty frustrating to find the SXM tuned to channel 1 over and over when you start the truck. Kinda makes me miss push buttons! That sumbitch was always where I left it:)
 

UNifc6pF

Active Member
Joined
May 28, 2021
Messages
120
Reaction score
159
I read above about outside interference causing issues with wireless CarPlay. Decided to give plug-in only go. Deleted profile on phone and truck. And sure enough it doesn't drop near as often. This is highly frustrating b/c the signal shouldn't be so senstive to be knocked out by outside sources. If wifi and bluetooth were that senstive no one in the area would have any wifi either. This is an issue with either the head unit or the phone :/

Still having issues with it cutting out randomly. Where the Home button and Car Play button won't work and won't switch appropriatley. And today the map only loaded on half the CarPlay screen and I could see the bottom half of the make (likely from Car Play widget and Uconnect not resizing correctly) And then CarPlay just wouldn't load on the screen on at all but yet audio will still play through CarPlay.

I miss the convenience of the wireless, especially b/c I accidentally unplug the phone sometimes when grabbing it or getting to stuff in my center console.
 

jsalbre

Well-Known Member
Joined
Oct 29, 2019
Messages
1,330
Reaction score
1,481
Location
ID
I read above about outside interference causing issues with wireless CarPlay. Decided to give plug-in only go. Deleted profile on phone and truck. And sure enough it doesn't drop near as often. This is highly frustrating b/c the signal shouldn't be so senstive to be knocked out by outside sources. If wifi and bluetooth were that senstive no one in the area would have any wifi either. This is an issue with either the head unit or the phone :/

Still having issues with it cutting out randomly. Where the Home button and Car Play button won't work and won't switch appropriatley. And today the map only loaded on half the CarPlay screen and I could see the bottom half of the make (likely from Car Play widget and Uconnect not resizing correctly) And then CarPlay just wouldn't load on the screen on at all but yet audio will still play through CarPlay.

I miss the convenience of the wireless, especially b/c I accidentally unplug the phone sometimes when grabbing it or getting to stuff in my center console.
Unfortunately a lot of cars have “sensitive” wireless CarPlay. The power they use for wifi is very low so as not to interfere with stationary services, and that leads to it being quite susceptible to interference.
 

UNifc6pF

Active Member
Joined
May 28, 2021
Messages
120
Reaction score
159
Unfortunately a lot of cars have “sensitive” wireless CarPlay. The power they use for wifi is very low so as not to interfere with stationary services, and that leads to it being quite susceptible to interference.
That's what I figured. It was a head unit issue due to too lower power. Again, something fairely easy to test for and plan around.
 

AndyBern

New Member
Joined
Dec 11, 2022
Messages
5
Reaction score
5
I just got a 2022 Ram 2200 with an 8" uConnect and no nav subscription. It's glitchy as well. Sometimes it works, sometimes it doesn't. Sometimes it detects my phone over Bluetooth, sometimes it doesn't. Sometimes it detects my USB thumb drive, sometimes it doesn't (even after repeated removal/reinsertion). Sometimes it remembers what media it was playing before when I start the truck, sometimes it plays Sirius regardless. I'm a programmer, and I'd be embarrassed to release code this buggy.

One thing I noticed and I'm not sure if that's the way it was designed or it's a glitch: when I play MP3s from my phone over bluetooth, if playback is interrupted (truck turned off, phone call, etc), when it resumes it always starts at the beginning of the next track. It does not continue where it left off. Is that normal with uconnect?
 

MikeXM

Well-Known Member
Joined
Nov 30, 2019
Messages
816
Reaction score
743
One thing I noticed and I'm not sure if that's the way it was designed or it's a glitch: when I play MP3s from my phone over bluetooth, if playback is interrupted (truck turned off, phone call, etc), when it resumes it always starts at the beginning of the next track. It does not continue where it left off. Is that normal with uconnect?
uconnect 4 restarts exactly where it was interrupted. not sure why 5 would be different .
 

AndyBern

New Member
Joined
Dec 11, 2022
Messages
5
Reaction score
5
Playing music from the flash drive works fine; only my BT works this way. I was looking for a setting on the phone or truck for it, but didn't find it. (The phone is set up right anyway, because continues where it left off on other BT playback devices.)
 

MikeXM

Well-Known Member
Joined
Nov 30, 2019
Messages
816
Reaction score
743
Playing music from the flash drive works fine; only my BT works this way. I was looking for a setting on the phone or truck for it, but didn't find it. (The phone is set up right anyway, because continues where it left off on other BT playback devices.)
fyi: never tried from flashdrive, my comment is for BT only.
 

Hootmonn

New Member
Joined
Mar 14, 2021
Messages
6
Reaction score
2
Location
Winter Park, CO
All the same issues. 2022 3500 Laramie Cummins. Over the air updates are useless and driving 60 Miles over the pass for an appointment that may or may not help is unacceptable when USB drives were able to update versions of the software before Uconnect 5.
When is it time to get the lawyers involved? This is a never ending mess.
 

baker01

Member
Joined
Nov 16, 2021
Messages
50
Reaction score
59
I received the OTA S26.17 update in mid-December. So far, I have lost the ability to zoom the rear-view camera multiple times. A soft reboot fixes it for a while. My home screen (CarPlay top Media bottom) has gone black. Other screens work the only way to fix it was a soft reboot. Sometimes after making a phone call, the left speakers stay in the lower volume (diminished) state. Turning off the truck or a soft reboot fixes the issue.
 

zGhillie

Member
Joined
Oct 8, 2021
Messages
67
Reaction score
81
All the same issues. 2022 3500 Laramie Cummins. Over the air updates are useless and driving 60 Miles over the pass for an appointment that may or may not help is unacceptable when USB drives were able to update versions of the software before Uconnect 5.
When is it time to get the lawyers involved? This is a never ending mess.
USB updates work on uc5 as well
 

techman

Active Member
Joined
Apr 5, 2022
Messages
153
Reaction score
155
Holy cow...that's a lot of problems across the board. I'm trying to see a common thread and it isn't clear. Was thinking that the phone type and OS version might be a factor.

Not to be a dissenting opinion, but I have had zero issues with AA and using a wireless connection. Sony phone, Android 12, and current version of Uconnect 5. I spent 20 hours in the truck over the holiday traveling nearly 800 miles in rural and city areas. Using audio, NAV, phone, and text.

So, there is hope. I would suggest pressuring your dealers to fix or replace.
 

zGhillie

Member
Joined
Oct 8, 2021
Messages
67
Reaction score
81
Holy cow...that's a lot of problems across the board. I'm trying to see a common thread and it isn't clear. Was thinking that the phone type and OS version might be a factor.

Not to be a dissenting opinion, but I have had zero issues with AA and using a wireless connection. Sony phone, Android 12, and current version of Uconnect 5. I spent 20 hours in the truck over the holiday traveling nearly 800 miles in rural and city areas. Using audio, NAV, phone, and text.

So, there is hope. I would suggest pressuring your dealers to fix or replace.
Nothing to replace. Just have to get updates to make things work better and dealers will not do usb update just say to wait for ota that never come. I’ve updated a few times myself and most issues have been fixed. When I first got the truck radio was unusable.
 

2019_Ram

Active Member
Joined
Sep 7, 2019
Messages
130
Reaction score
134
I received the 26.17 update and seem to have lost the ability to pickup HD radio stations. I still see and can toggle the HD radio icon, but no longer can receive those. I even did a factory reset and nothing changed.
 

Users who are viewing this thread

Top